Minor: Application experiencing degradation
Resolved·Degraded performance
Sat, Oct 18, 2025, 03:04 PM
(5 hours ago)
·
Affected components
App
Updates

Resolved

The incident has been resolved.

Sat, Oct 18, 2025, 03:04 PM

Investigating

The Lumen5 application is experiencing degraded service. The team has been notified and is working to resolve the issue. Please stay tuned for updates.

Fri, Oct 17, 2025, 08:05 PM(18 hours earlier)