Minor: Application experiencing degradation
Resolved·Degraded performance
Thu, May 22, 2025, 10:00 PM
(1 week ago)
·
Affected components
App
Updates

Resolved

The incident has been resolved.

Thu, May 22, 2025, 10:00 PM

Investigating

The Lumen5 application is experiencing degraded service. The team has been notified and is working to resolve the issue. Please stay tuned for updates.

Wed, Apr 9, 2025, 06:02 PM(1 month earlier)